NA Miata Ignition Switch Replacement / Refurbish

This is a very small topic, but it’s been an intermittent pain for me over the past several years. See, once in a while, Sharka just won’t start. It hasn’t happened often or repeatedly, so I haven’t been able to fix it and I haven’t spent much time on it. Lately, the problem started to get worse and action was required.

The problem manifested itself in a warm or hot car that did nothing when I pressed the start button. No weak starter chug. Just nothing at all. I replaced the starter button relay a couple times (using extremely nice relays) only to see the problem return a few months later.

I should note here how my starter button works – it replaces the final twist of the key. So I have to turn the key to “on” and then press the start button. This is how Sharka has started for the past 20 years and this hasn’t given me any problems. Also, I never had a problem when the car was cold. Specifically when the INTERIOR was cold. If the car parked out in the sun for a while and the interior heated up, restarting was likely to require some effort. Sometimes a good 30 seconds of pushing that start button before something finally clicked.

After a bit of troubleshooting (literally replacing EVERY part in my start button system) and still having the problem, some googling revealed that the ignition switch itself was likely to blame. They are, apparently, “known trouble spots on the NA Miata” according to the Miata.net forum. And… honestly, that’s news to me. I’ve only owned an NA for 21 years. I’ve never changed out the ignition switch. But the part wasn’t expensive and reports of changing it or cleaning it were bright, so I went ahead and ordered.

Ignition Switch on the NA

Ignition Switch on the NA

Unlike other cars I’ve owned that have needed this swapped out, the NA switch sits opposite the key. It plugs into a long metal cylinder that the key slides into. This isn’t hard to find or remove. Removing that panel underneath the steering wheel is required.

Removed.

Old vs New

A couple screws later, the switch is out. Note the yellow plastic. I’m pretty sure that’s not the original color, but rather plastic that’s weathered over the years.

I’ll be honest, up to this point I wasn’t 100% certain that the replacement switch in the first photo of this post was the right part number. It truly doesn’t look like any other ignition switch I’ve ever handled. In other words, Honda ones are quite different. But it installed perfectly.

Installed!

Bam! That’s all there is to it. Slide it back into the metal cylinder and tighten the couple screws. With any luck, Sharka will be good for another 20 years with this new switch.

Still, I bought a spare one after verifying that this was the correct part. Parts sometimes dry up, so grab a D001-66-151A from your local Mazda parts counter while you can.

Annnd… if you can’t… I took a few more photos.

Refurbishing the NA Ignition Switch

Please use the photos below as reference only. I took my ancient stock switch apart but did not test it to see if my repair was a success. I just wanted to document what lived inside the plastic.

Sleeve removed.

The switch comes in two pieces and that outer sleeve just slides off. Nothing needs to be unsnapped to do this. With the prongs accessible, they can be sanded and cleaned up.

To get inside the switch, you’ll need to crack the brittle plastic case open. I was extremely careful but still broke one of the two tabs that keep it together. Beware.

Disassembly 1

The switch is coated in dielectric grease on the inside. This should be cleaned away and replaced with fresh dielectric grease. Do NOT reassemble the switch dry. It needs that grease to keep everything lubricated and able to spin.

Make note of how the two inner copper halves fit together. There are springs underneath and they only fit together one way.

Ready for cleaning.

I do not advise you to take this switch apart further. The black half that’s left inside the housing has a handful of springs and two spring loaded ball bearings holding it together. None of those items need servicing or cleaning in my opinion. All of the parts you want to clean are visible above.

Carefully sand any corrosion and wear marks from those two copper halves. Clean off all the grease. Sand the terminals on the first, largest black plastic piece as well (the one covered in grease). Get everything nice and shiny. Then re-grease and reinstall.

With any luck, your switch will be restored to like-new condition and will not need servicing for a few years. With bad luck, you might break your housing and need to buy a replacement switch. But either way, hopefully this blog post will help you get your car starting again.

As for Sharka, the little guy has started strong each and every time since installing the new ignition switch 3 months back. I’m happy to report that this fixed the problem.

« |
  • Alan Baker says:

    Hey, consider yourself lucky.

    In a fit of ridiculousness, Canadian Miatas were wired differently, and some relays were omitted…

    …leaving the ignition switch to carry the full current to run things like the heater fan motor, and windshield wipers.

    When I finally got tired of wondering, “What’s that smell and where’s it coming from?”, I found my ignition switch and the connector that plugged into it half melted.

  • Larry Hopper says:

    Thank you for another interesting article.

    I used a right-angle, ratcheting screwdriver to replace my 1997’s ignition switch. I still had the intermittent starting problem, which I finally solved by replacing the clutch safety switch.

  • Jim says:

    Adam,

    Great, essential write up!

    In 30 years and more 350k miles have replaced Ginya’s ignition switch at least 4 times.

    And yes, as noted by Alan Baker above, that mysterious burning smell is the sign.

    And as you know, I’ve chased that” hot won’t, start problem” 100 ways … Any sort of imperfect wiring connected to the ignition is likely to enhance the issue.

    Jim

  • Dave says:

    I should have looked here first! My “no-start” problem cropped up at the most inopportune times (like the time the car was sitting silently on the dyno at the smog station and the operator looked at me and said: “can you show me how to start your car?” It didn’t, and I had to be pushed off the rollers and made to “go-away!”).
    After replacing/cleaning all of the ground connections the issue was still there, so, finally I learned about the ignition switch and yes mine was a real mess (not a Canadian car but I used to live there so maybe negative karma followed me to Arizona?).
    One thing, when popping the multi-connector onto your new switch, watch out for one of the “hot” wires sliding right out the back of the plastic connector, I didn’t notice at first so “no-start” continued until I found the culprit!
    Take Care

  • Leave a Reply to Larry Hopper